?

Log in

Nyaaaargh!!! (rassin-frassin LJ) - Smiling silently... [entries|archive|friends|userinfo]
Cheshyre

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

Nyaaaargh!!! (rassin-frassin LJ) [Jan. 9th, 2007|07:11 pm]
Cheshyre
Twice now, I've tried to leave a comment on somebody else's journal, only to get
Error Invalid form submission. Please refresh and try again.
And because LJ uses these fancy dynamically-generated forms instead of the old ?mode=reply URL, the browser back button won't work to access my comment text. In fact, I don't know of ANY way of going back to recopy the text I wrote.

Thanks for the "update" LJ!
linkReply

Comments:
[User Picture]From: cheshyre
2007-01-10 12:14 am (UTC)
Yup, and refreshing my browser on talkpost_do.bml, it's now lost my post content as well:
One or more errors occurred processing your request. Please go back, correct the necessary information, and submit your data again.
  • Comment not posted: POST required, or missing parameter.
  • (Reply) (Thread)
    [User Picture]From: ron_newman
    2007-01-10 12:20 am (UTC)
    This has happened to me, too. Does anyone know where to find the parameter? It's not anywhere in my user profile, as far as I can see.
    (Reply) (Parent) (Thread)
    [User Picture]From: jimhines
    2007-01-10 12:32 am (UTC)
    When that error message comes up, don't click the back button. I hit Refresh. It says it will need to resubmit my form data, and I tell it okay. Usually it then goes ahead and posts my comment...

    I'm in IE 7, for what it's worth. Don't know how reliable this is, or whether it will work in other browsers.
    (Reply) (Parent) (Thread)
    [User Picture]From: marnanel
    2007-03-13 12:31 pm (UTC)
    Works fine in Firefox.
    (Reply) (Parent) (Thread)
    [User Picture]From: filkerdave
    2007-01-10 12:49 am (UTC)
    When that happens, I just hit refresh and that usually works.
    (Reply) (Parent) (Thread)
    [User Picture]From: gilmoure
    2007-01-10 12:20 am (UTC)
    Just had that happen, out at crevette's LJ. I hit submit and got same error. I hit the back button (Firefox) and my comment window was gone. I clicked on Leave a Comment and the comment window opened up with my comment in there. Weird!
    (Reply) (Thread)
    [User Picture]From: redbird
    2007-01-10 02:07 am (UTC)
    Another weird thing is that if I start to type a comment in a long thread, think better of it, and then click to reply to another comment, LJ pastes in the text of the first comment.

    This has yet to get me into trouble, but I suspect it will, and I'm virtually certain it's bitten other people. (If the first comment is talking about giving my nephew birthday presents, and the second about biking to school, that's probably safe; anything along the lines of "I agree with you" could easily lead to misunderstanding if pasted in the wrong place.)
    (Reply) (Parent) (Thread)
    [User Picture]From: dejla
    2007-01-10 01:31 am (UTC)
    Hmmm. Usually that happens to me when I've replied from my email and I'm not logged in.
    (Reply) (Thread)
    [User Picture]From: brooksmoses
    2007-01-10 04:24 am (UTC)
    Argh, indeed!

    (It's this sort of thing that's a large part of why I use Opera. At least in the version I use, the back button always takes me back to the previous page exactly as it was when I left it. Or, for that matter, the forward button, too. But this comment is not meant to imply that because a different browser provides a workaround for the problem you have no reason to gripe.)
    (Reply) (Thread)
    [User Picture]From: cheshyre
    2007-01-10 04:54 am (UTC)
    I'm using Opera, too.
    From a page like this (http://cheshyre.livejournal.com/56482.html?replyto=505250) the back button works. But not if you use the new inline commenting.
    (Reply) (Parent) (Thread)
    [User Picture]From: brooksmoses
    2007-01-10 05:04 am (UTC)
    Huh. Okay, I guess I just haven't ever run into that then -- if I don't click "Submit" on the inline comment, it stays there when I go "back" to it, but I bet the Javascript on the page makes the text box go away when the submit-click happens, before it actually tries to load the confirmation page, and Opera doesn't backtrack the Javascript.

    Ugh, indeed.
    (Reply) (Parent) (Thread)
    [User Picture]From: mactavish
    2007-01-10 05:41 am (UTC)
    Odd, I still get the reply URL, and can get my text when I have to go back.
    (Reply) (Thread)
    [User Picture]From: livredor
    2007-01-10 09:10 am (UTC)
    There's a nasty ongoing bug (maybe several) which are causing lots and lots of those annoying errors with posting comments. Until it's fixed, maybe you want to turn off the fancy dynamic comment forms? You can go back to the old ?mode=reply separate page if you use the console command set disable_quickreply 1
    (Reply) (Thread)
    [User Picture]From: rosefox
    2007-01-10 04:01 pm (UTC)
    You can turn that option off and go back to the old mode=reply style.
    (Reply) (Thread)
    From: dentenozivi
    2012-02-16 03:36 am (UTC)
    Спасибо за инфу
    (Reply) (Thread)